[OTR-dev] finch & otr

Howard Chu hyc at symas.com
Thu Jul 4 20:42:39 EDT 2013

kardan wrote:
> On Thu, 4 Jul 2013 12:16:00 -0400
> Ian Goldberg <ian at cypherpunks.ca> wrote:
>> On Thu, Jul 04, 2013 at 02:50:57AM +0200, kardan wrote:
>>> On Wed, 3 Jul 2013 14:36:26 -0400
>>> Ian Goldberg <ian at cypherpunks.ca> wrote:
>>>>> checking for libotr headers version 3.x >= 3.2.0... not present.
>>>>> I stared to long at this. Is it me or is the compiler not
>>>>> accepting the installed libs?
>>>> The above error says it can't find the libotr 3.x headers, which
>>>> is possibly because you've got the libotr 4.x headers installed.
>>>> What does your /usr/include/libotr/version.h say?
>>> You are right again, it says
>>> #define OTRL_VERSION "4.0.0"
>> There you go, then.  You'll need the libotr 3.x headers and libraries
>> to compile an application that expects that version of libotr.
> Sure, just easy as that.. I think I was too confused be the previous
> errors and forgot to install all dependencies. Added a hint to INSTALL.
> In finch I found no way to authenticate the buddy. The option dialogue
> for the message window (CTRL+o/F10) does not offer it. Is this
> implemented?

Yes it does and yes it is. Use the option dialogue, notice that this dialogue 
has a second page.

> Also one dialogue (buddy list -> F11 -> OTR preferences) shows "_Set"
> and "_Cancel". I wonder how to translate this as it does not appear in
> po/de.po, only in
> purple-ui.c:210:        _("_Set"), G_CALLBACK(config_buddy_cb),
> purple-ui.c:211:        _("_Cancel"), NULL,
> otr-plugin.c:1071:      _("_Cancel"), NULL,

> Please give feedback if the attached patches are useful in this way.

> --- a/INSTALL
> +++ b/INSTALL
> @@ -14,6 +14,8 @@ libtool, intltool, etc.
>  If you install these with a package manager, you'll probably need the
>  -dev or -devel versions of the packages.
> +For debian run: apt-get install libotr2-dev libpurple-dev libgpgme11-dev libgcrypt11-dev automake intltool
> +
>  The pidgin 2.10.1 source needs a few patches for everything to work
>  properly. You can get these patches here:
>  	http://developer.pidgin.im/ticket/14818

Distro-specific instructions are inappropriate here. The doc already tells you 
you need libotr 3.1.0, libgcrypt 1.2.0, and the pidgin 2.10.1 source + the 4 
additional patches. You should already know how to get such things for 
whatever distro you use. A person who can read and follow directions would 
simply grab the versions of the source code specified from the URLs provided 
in the docs.

If you had simply grabbed the source from gitorious and run the configure 
script as provided, you wouldn't need to mess around with "missing" or 
anything else.

   -- Howard Chu
   CTO, Symas Corp.           http://www.symas.com
   Director, Highland Sun     http://highlandsun.com/hyc/
   Chief Architect, OpenLDAP  http://www.openldap.org/project/

More information about the OTR-dev mailing list